Основы. Счета и субсчета - Основы - 1С v.7.7 - Каталог статей - Программирование в 1С
Программирование в 1СВоскресенье, 11.12.2016, 04:12

| RSS
Главная | Каталог статей
Меню сайта

Категории раздела
Основы [36]
Общие вопросы по 1С 7.7 [88]
1С: Бухгалтерия 7.7 [7]
1С: Торговля 7.7 [4]
1С:Зарплата и кадры 7.7 [1]
1С 7.7: Проблемы и решения [33]
УРБД [3]
Управление Распределенными Базами Данных
OLE [2]
Механизм обмена данными между базами 1С через OLE
SQL [1]
Сервер терминалов [1]
Интеграция с внешними приложениями [3]
FAQ по 1С v.7.7 [7]
FAQ по 1С v.7.7

Поиск

Поиск по сайту

Главная » Статьи » 1С v.7.7 » Основы

Основы. Счета и субсчета
Счета и субсчета

    Счета могут объединяться в группы. Счет, который является группой, называется “синтетический счет”. Счет, который входит в группу, называется “субсчет”. Для работы с такими счетами применяются следующие методы:

ЭтоГруппа() – Определяет, является ли данный счет группой (может иметь субсчета) или нет.
Возвращает: 1 – счет является группой; 0 – счет не является группой.

Пример – вывести все синтетические счета:

Счета = СоздатьОбъект(“Счет.ОснПлан”);
Счета.ВыбратьСчета();
Пока Счета.ПолучитьСчет()=1 Цикл
....Если Счета.ЭтоГруппа()=1 Тогда
..........Сообщить(Счета.Код + “ “ + Счета.Наименование);
....КонецЕсли;
КонецЦикла;

ИспользоватьРодителя(<Счет>) – Устанавливает / выдает значение родителя (счета вышестоящего уровня), используемого для выборки счетов. Возвращает: значение типа ‘‘Счет’‘ – текущее значение используемого родителя на момент до исполнения метода.

Пример – вывести все субсчета счета “10 Материалы”:

Счета = СоздатьОбъект(“Счет.ОснПлан”);
Сч10 = СчетПоКоду(10);
Счета.ИспользоватьРодителя(Сч10);
Счета.ВыбратьСчета();
Пока Счета.ПолучитьСчет()=1 Цикл
.....Сообщить(Счета.Код + “ “ + Счета.Наименование);
КонецЦикла;

Уровень() – Возвращает уровень вложенности текущего счета. (возвращает 1 – для счета верхнего уровня)

Пример – вывести все счета в виде дерева:

Счета = СоздатьОбъект(“Счет.ОснПлан”);
Счета.ВыбратьСчета();
Пока Счета.ПолучитьСчет()=1 Цикл
     отступ = “”;
     Для ном = 1 По Счета.Уровень() Цикл
     ....отступ = отступ + “ “;
     КонецЦикла;
     Сообщить(отступ + Счета.Код + “ “ + Счета.Наименование);
КонецЦикла;

ПринадлежитГруппе(<Счет>) – Определяет, является ли текущий счет субсчетом для счета, указанного в качестве параметра метода. Проверка выполняется по всем вышестоящим уровням счета. Возвращает: 1 – текущий счет является субсчетом для счета, указанного в качестве параметра; 0 – не является.

Пример:

Сч10 = СчетПоКоду(“10”);
СубСч10 = СчетПоКоду(“10.5.1”);
Сообщить(СубСч10.ПринадлежитГруппе(Сч10)); //метод вернет 1

Родитель(<НомерУровня>) – Возвращает счет вышестоящего уровня для данного счета. <НомерУровня> – число, которое определяет, какого уровня вышестоящий счет должен быть выдан. Если параметр не указан – выдается непосредственный родитель.
Например, для счета “10.5” этот метод вернет счет с кодом “10”.

КодСубсчета() – Выдает код счета без кодов счетов вышестоящих уровней.
Возвращает: строковое значение – код счета без кодов счетов вышестоящих уровней.
Например, для счета “10.5” этот метод вернет строковое значение “5”.

ВыборГруппы(<флаг>) – Этот метод устанавливает режим выборки групп. Данный метод может применяться как для позиционируемых объектов, созданных функцией ‘‘СоздатьОбъект’‘, так и для элементов диалога типа ‘‘Счет’‘. По умолчанию выбор группы разрешен, за исключением счетов дебета и кредита в проводках операции.

ВыбрСчет.ВыборГруппы(1); //разрешить выбор группы
ВыбрСчет.ВыборГруппы(0); //запретить выбор группы
Категория: Основы | Добавил: Spacer (07.05.2008)
Просмотров: 3210 | Теги: Субсчет, счет
Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz

  • Статистика

    Copyright 1C:Programmer © 2016
    Бесплатный конструктор сайтов - uCoz