Основы. Создание, удаление и корректировка счетов - Основы - 1С v.7.7 - Каталог статей - Программирование в 1С
Программирование в 1СВоскресенье, 11.12.2016, 04:11

| RSS
Главная | Каталог статей
Меню сайта

Категории раздела
Основы [36]
Общие вопросы по 1С 7.7 [88]
1С: Бухгалтерия 7.7 [7]
1С: Торговля 7.7 [4]
1С:Зарплата и кадры 7.7 [1]
1С 7.7: Проблемы и решения [33]
УРБД [3]
Управление Распределенными Базами Данных
OLE [2]
Механизм обмена данными между базами 1С через OLE
SQL [1]
Сервер терминалов [1]
Интеграция с внешними приложениями [3]
FAQ по 1С v.7.7 [7]
FAQ по 1С v.7.7

Поиск

Поиск по сайту

Главная » Статьи » 1С v.7.7 » Основы

Основы. Создание, удаление и корректировка счетов
Создание, удаление и корректировка счетов

    Обычно счета создаются вручную в режиме Конфигуратор или Предприятие. Но иногда может потребоваться программная корректировка списка счетов.

Счета = СоздатьОбъект(“Счет.Основной”);
Счета.Новый(1); //у счета будут субсчета
Счета.Код = “10”;
Счета.Наименование = “Материалы”;
Счета.Активный = 1; //активный
Счета.Записать();

Счета.Новый();
Счета.Код = “10.1”;
Счета.Наименование = “Основные материалы”;
Счета.ВидСубконто(1,ВидыСубконто.Материалы);
Счета.ВидСубконто(2,ВидыСубконто.Склады);
Счета.Записать();

Пример – изменить наименование счета:

Счета = СоздатьОбъект(“Счет.Основной”);
Счета.НайтиПоКоду(“10”);
Счета.Наименование = “Все материалы”;
Счета.Записать();

Пример – пометить на удаление все счета, введенные пользователем в режиме “Предприятие”. Оставить только счета, заданные разработчиком в Конфигураторе.

Счета = СоздатьОбъект(“Счет.Основной”);
Счета.ВыбратьСчета();
Пока Счета.ПолучитьСчет()=1 Цикл
.....Если Счета.ЗаданВКонфигурации()=0 Тогда
.........Счета.Удалить(0); //пометить на удаление
.....КонецЕсли;
КонецЦикла;

Пример – отменить все пометки на удаление:

Счета = СоздатьОбъект(“Счет.Основной”);
Счета.ВыбратьСчета();
Пока Счета.ПолучитьСчет()=1 Цикл
.....Если Счета.ПометкаУдаления()=1 Тогда
.........Счета.СнятьПометкуУдаления();
.....КонецЕсли;
КонецЦикла;
Категория: Основы | Добавил: Spacer (09.05.2008)
Просмотров: 2069
Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz

  • Статистика

    Copyright 1C:Programmer © 2016
    Бесплатный конструктор сайтов - uCoz