Основы. Поиск элемента в справочнике - Основы - 1С v.7.7 - Каталог статей - Программирование в 1С
Программирование в 1СВоскресенье, 11.12.2016, 04:09

| RSS
Главная | Каталог статей
Меню сайта

Категории раздела
Основы [36]
Общие вопросы по 1С 7.7 [88]
1С: Бухгалтерия 7.7 [7]
1С: Торговля 7.7 [4]
1С:Зарплата и кадры 7.7 [1]
1С 7.7: Проблемы и решения [33]
УРБД [3]
Управление Распределенными Базами Данных
OLE [2]
Механизм обмена данными между базами 1С через OLE
SQL [1]
Сервер терминалов [1]
Интеграция с внешними приложениями [3]
FAQ по 1С v.7.7 [7]
FAQ по 1С v.7.7

Поиск

Поиск по сайту

Главная » Статьи » 1С v.7.7 » Основы

Основы. Поиск элемента в справочнике
Поиск элемента в справочнике

Поиск элемента:

СпрСотр = СоздатьОбъект(“Справочник.Сотрудники”);
Если СпрСотр.НайтиЭлемент(ВыбрСотр)=1 Тогда
....//элемент становится текущим
....СпрСотр.Родитель = грпРаботающие;
....СпрСотр.Записать();
КонецЕсли;

Поиск по коду:

Если СпрСотр.НайтиПоКоду(1) = 1 Тогда
....ЭлементИлиГруппа = СпрСотр.ТекущийЭлемент();
КонецЕсли;

Поиск по наименованию:

Если СпрСотр.НайтиПоНаименованию(“Работающие”)=1 Тогда
....грпРаботающие = СпрСотр.ТекущийЭлемент();
КонецЕсли;
Режим = 1; // 1 – поиск внутри установленного подчинения (родителя) (по умолч.); 0 – поиск во всем справочнике
ФлагПоиска = 0; //1 – найти точное соответствие; 0 – найти наименование по первым символам (по умолчанию)
СпрСотр.ИспользоватьРодителя(грпРаботающие);
Если СпрСотр.НайтиПоНаименованию(“Ив”,Режим,ФлагПоиска)=1 Тогда
....ПервыйРаботающийИв = СпрСотр.ТекущийЭлемент();
КонецЕсли;

Поиск по реквизиту:

ИмяРекв = “Год”; //у реквизита должен быть установлен флажок Сортировка в Конфигураторе
ФлагГлобПоиска = 1; // 1- искать во всем справочнике, 0 – искать в пределах подчинения
Если СпрСотр.НайтиПоРеквизиту(ИмяРекв,1980,ФлагГлобПоиска)=1 Тогда
.....НайденныйЭлемент = СпрСотр.ТекущийЭлемент();
КонецЕсли;

Поиск элемента в цикле:

СпрСотр = СоздатьОбъект(“Справочник.Сотрудники”);
СпрСотр.ИспользоватьРодителя(грпРаботающие);
СпрСотр.ИспользоватьДату(РабочаяДата());
СпрСотр.ВыбратьЭлементы();
Пока СпрСотр.ПолучитьЭлемент()=1 Цикл
Если СпрСотр.Должность = длжПлотник Тогда
....Прервать; //нашли работающего плотника! выйти из цикла
КонецЕсли;
КонецЦикла;
<действия с найденным элементом>
Категория: Основы | Добавил: Spacer (20.05.2008)
Просмотров: 6018 | Теги: справочник
Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz

  • Статистика

    Copyright 1C:Programmer © 2016
    Бесплатный конструктор сайтов - uCoz