Основы. Организация подбора. Установка и получение значений из подбора - Основы - 1С v.7.7 - Каталог статей - Программирование в 1С
Программирование в 1СВоскресенье, 04.12.2016, 01:49

| RSS
Главная | Каталог статей
Меню сайта

Категории раздела
Основы [36]
Общие вопросы по 1С 7.7 [88]
1С: Бухгалтерия 7.7 [7]
1С: Торговля 7.7 [4]
1С:Зарплата и кадры 7.7 [1]
1С 7.7: Проблемы и решения [33]
УРБД [3]
Управление Распределенными Базами Данных
OLE [2]
Механизм обмена данными между базами 1С через OLE
SQL [1]
Сервер терминалов [1]
Интеграция с внешними приложениями [3]
FAQ по 1С v.7.7 [7]
FAQ по 1С v.7.7

Поиск

Поиск по сайту

Главная » Статьи » 1С v.7.7 » Основы

Основы. Организация подбора. Установка и получение значений из подбора
Организация подбора. Установка и получение значений из подбора

Организация подбора:

Синтаксис:

ОткрытьПодбор(<Объект>,<ИмяФормы>,<КонтекстФормы>, <ФлагМножВыбора>,<ТекЗнач>);

ОткрытьПодбор(“Справочник.Номенклатура”,“ФормаДляПодбора”,Конт,1);
Процедура ОбработкаПодбора(Элемент,КонтФормы)
...НоваяСтрока();
...Товар = Элемент;
КонецПроцедуры
 
Функция подбора позволяет выбирать несколько значений из справочника или другого объекта, не закрывая его. Например, есть документ РасходнаяНакладная, в котором пользователь может указать несколько товаров.

Синтаксис:
ОткрытьПодбор(<Объект>,<ИмяФормы>, <КонтекстФормы>,<ФлагМножВыбора>,<ТекЗнач>)

ОткрытьПодбор(“Справочник.Номенклатура”,“ФормаДляПодбора”,Конт,1);
Процедура ОбработкаПодбора(Элемент,КонтФормы)
...НоваяСтрока();
...Товар = Элемент;
КонецПроцедуры

    Можно воспользоваться контекстом формы и сразу перейти в нужную группу, например:

ОткрытьПодбор(“Справочник.Номенклатура”,“ФормаДляПодбора”,Конт,1);
Конт.ИспользоватьРодителя(грпСпиртное);
Процедура ОбработкаПодбора(Элемент,КонтФормы)
...НоваяСтрока();
...Товар = Элемент;
КонецПроцедуры

Установка и получение значений из подбора:

КонтФормыПодбора.УстановитьЗначениеВПодборе(<ИмяРеквизита>,<Значение>)
<ИмяРеквизита> – строка с именем реквизита формы подбора значения;
<Значение> – значение реквизита.

КонтФормыПодбора.ПолучитьЗначениеИзПодбора(<Выражение>)
<Выражение> – строковое выражение, значение которого вычисляется в контексте формы подбора и возвращается в качестве результата.
Категория: Основы | Добавил: Spacer (21.05.2008)
Просмотров: 3679 | Теги: справочник
Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz

  • Статистика

    Copyright 1C:Programmer © 2016
    Бесплатный конструктор сайтов - uCoz