Основы. Работа с формами - Основы - 1С v.7.7 - Каталог статей - Программирование в 1С
Программирование в 1СВоскресенье, 11.12.2016, 04:12

| RSS
Главная | Каталог статей
Меню сайта

Категории раздела
Основы [36]
Общие вопросы по 1С 7.7 [88]
1С: Бухгалтерия 7.7 [7]
1С: Торговля 7.7 [4]
1С:Зарплата и кадры 7.7 [1]
1С 7.7: Проблемы и решения [33]
УРБД [3]
Управление Распределенными Базами Данных
OLE [2]
Механизм обмена данными между базами 1С через OLE
SQL [1]
Сервер терминалов [1]
Интеграция с внешними приложениями [3]
FAQ по 1С v.7.7 [7]
FAQ по 1С v.7.7

Поиск

Поиск по сайту

Главная » Статьи » 1С v.7.7 » Основы

Основы. Работа с формами
Открытие формы

Формы – это основной вид диалога с пользователем. Все справочники, документы, журналы, отчеты и обработки имеют экранные формы. Обычно форма открывается пользователем интерактивно (мышкой), но форму можно открыть и программно.

Конт = 0; //контекст формы (ссылка на форму)
ОткрытьФорму(“Справочник.Сотрудники.Основная”,Конт); //открыть форму списка справочника
ОткрытьФорму(ВыбрСотрудник); //открыть форму элемента справочника
ОткрытьФорму(“Отчет.ГлавнаяКнига”);
ОткрытьФорму(“Документ.ПриемНаРаботу”,Конт); //новый документ
//можно открыть форму модально и еще можно передать в форму параметр
//в модуле формы переданный параметр доступен через конструкцию
Форма.Параметр
ОткрытьФормуМодально(“Обработка.УсловияПоиска”,10);
 
Элементы диалога на форме

В модуле формы к элементам диалога можно обращаться по их идентификаторам через конструкцию Форма.ЭлементДиалога:
 
Форма.Сотрудник.Доступность(1); //сделать доступным
Форма.Сотрудник.Доступность(0); //сделать недоступным

Форма.Сотрудник.Видимость(1); //сделать видимым
Форма.Сотрудник.Видимость(0); //сделать невидимым

//можно менять заголовки на кнопке и на других элементах диалога
Форма.Кнопка.Заголовок(“Далее >>”);
Форма.Кнопка.Заголовок(“Готово!”);
//можно менять цвет элементов диалога
Если ВыбрСотрудник.Выбран()=0 Тогда
Форма.Надпись_Сотрудник.Цвет(200,50,50); //красный, зеленый, синий (RGB)
Активизировать(“ВыбрСотрудник”);
Иначе
Форма.Надпись_Сотрудник.Цвет(0,0,0);
КонецЕсли;
 
Слои и закладки на форме

Форма может состоять из нескольких слоев. Каждый слой может быть показан или скрыт в любой комбинации с другими слоями.
Синтаксис: Форма.ИспользоватьСлой(<ИмяСлоя>,[<Режим>])

//показать слой Основной
Форма.ИспользоватьСлой(“Основной”,1);
//скрыть слой Основной
Форма.ИспользоватьСлой(“Основной”,0);

//показать слой Основной и скрыть все остальные
Форма.ИспользоватьСлой(“Основной”,2);

//показать слой Основной и Фон и скрыть все остальные
Форма.ИспользоватьСлой(“Основной,Фон”,2);

//закладки на форме реализуются с помощью слоев
Форма.ИспользоватьЗакладки(1);
Форма.Закладки.ДобавитьЗначение(1, “Закладка 1”);
Форма.Закладки.ДобавитьЗначение(2, “Закладка 2”);
Процедура ПриВыбореЗакладки(НомерЗакладки, ЗначениеЗакладки)
Если НомерЗакладки = 1 Тогда
Форма.ИспользоватьСлой(“Фон,Шаг1”);
Иначе
Форма.ИспользоватьСлой(“Фон,Шаг2”);
КонецЕсли;
КонецПроцедуры
Категория: Основы | Добавил: Spacer (25.05.2008)
Просмотров: 10538 | Комментарии: 1 | Теги: форма
Всего комментариев: 1
1  
И как же передать параметр ИЗ формы в родительскую форму???

Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz

  • Статистика

    Copyright 1C:Programmer © 2016
    Бесплатный конструктор сайтов - uCoz