Перебор документов "в лоб" и с помощью запроса - Общие вопросы по 1С 7.7 - 1С v.7.7 - Каталог статей - Программирование в 1С
Программирование в 1СВоскресенье, 04.12.2016, 01:50

| RSS
Главная | Каталог статей
Меню сайта

Категории раздела
Основы [36]
Общие вопросы по 1С 7.7 [88]
1С: Бухгалтерия 7.7 [7]
1С: Торговля 7.7 [4]
1С:Зарплата и кадры 7.7 [1]
1С 7.7: Проблемы и решения [33]
УРБД [3]
Управление Распределенными Базами Данных
OLE [2]
Механизм обмена данными между базами 1С через OLE
SQL [1]
Сервер терминалов [1]
Интеграция с внешними приложениями [3]
FAQ по 1С v.7.7 [7]
FAQ по 1С v.7.7

Поиск

Поиск по сайту

Главная » Статьи » 1С v.7.7 » Общие вопросы по 1С 7.7

Перебор документов "в лоб" и с помощью запроса
Перебор документов "в лоб"
 
// Перебор всех документов
Док = СоздатьОбъект(“Документ”);
Док.ВыбратьДокументы(Дата1, Дата2);
Пока Док.ПолучитьДокумент() = 1 Цикл
Если Док.Вид() = “ВидДокумента” Тогда
// Дальнейшая обработка Док.ТекущийДокумент()
КонецЕсли;
КонецЦикла;


// Если нужно обработать документы определенного вида, тогда

Док = СоздатьОбъект(“Документ.ВидДокумента“);
Док.ВыбратьДокументы(Дата1, Дата2);
Пока Док.ПолучитьДокумент() = 1 Цикл
// Дальнейшая обработка Док.ТекущийДокумент()
КонецЦикла;
 
Перебор документов с помощью запроса
 
Запрос = СоздатьОбъект(“Запрос”);
ТекстЗапроса =
|Период с Дата1 по Дата2;
|ОбрабатыватьДокументы Проведенные;
|Реквизит = Документ.ВидДокумента.Реквизит;
|Группировка Реквизит;
|Группировка Документ;
|Группировка НомерСтроки;”;
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Предупреждение(“Запрос по документам не выполнился!”);
Возврат;
КонецЕсли;
// Теперь вся выборка находится в объекте “Запрос”
Категория: Общие вопросы по 1С 7.7 | Добавил: Spacer (02.06.2008)
Просмотров: 7430 | Теги: документ
Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz

  • Статистика

    Copyright 1C:Programmer © 2016
    Бесплатный конструктор сайтов - uCoz