Обход строк документа - Общие вопросы по 1С 7.7 - 1С v.7.7 - Каталог статей - Программирование в 1С
Программирование в 1СВоскресенье, 04.12.2016, 01:47

| RSS
Главная | Каталог статей
Меню сайта

Категории раздела
Основы [36]
Общие вопросы по 1С 7.7 [88]
1С: Бухгалтерия 7.7 [7]
1С: Торговля 7.7 [4]
1С:Зарплата и кадры 7.7 [1]
1С 7.7: Проблемы и решения [33]
УРБД [3]
Управление Распределенными Базами Данных
OLE [2]
Механизм обмена данными между базами 1С через OLE
SQL [1]
Сервер терминалов [1]
Интеграция с внешними приложениями [3]
FAQ по 1С v.7.7 [7]
FAQ по 1С v.7.7

Поиск

Поиск по сайту

Главная » Статьи » 1С v.7.7 » Общие вопросы по 1С 7.7

Обход строк документа
Обход строк документа
 
// Перебор строк документов
Док = СоздатьОбъект(“Документ”);
Док.ВыбратьДокументы(Дата1, Дата2);
Пока Док.ПолучитьДокумент() = 1 Цикл
    Если Док.Вид() = “ВидДокумента“ Тогда 
        // Далее идет собственно обход строк 
        Док.ВыбратьСтроки(); 
        Пока Док.ПолучитьСтроку() = 1 Цикл 
            // Обработка строки документа 
            // Доступ к реквизитам строки документа происходит через Док.Реквизит
 
        КонецЦикла;
        // Альтернативный вариант обхода строк
        КвоСтр = Док.КоличествоСтрок();
        Для НомСтр=1 По КвоСтр Цикл
            Док.ПолучитьСтрокуПоНомеру(НомСтр);
            // Обработка строки документа 
            // Доступ к реквизитам строки документа происходит через Док.Реквизит
 
        КонецЦикла;
    КонецЕсли;
КонецЦикла;
Категория: Общие вопросы по 1С 7.7 | Добавил: Spacer (03.06.2008)
Просмотров: 3405 | Теги: документ
Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz

  • Статистика

    Copyright 1C:Programmer © 2016
    Бесплатный конструктор сайтов - uCoz