Удаление строк из таблицы значений с позиционированием - Общие вопросы по 1С 7.7 - 1С v.7.7 - Каталог статей - Программирование в 1С
Программирование в 1СВоскресенье, 04.12.2016, 01:48

| RSS
Главная | Каталог статей
Меню сайта

Категории раздела
Основы [36]
Общие вопросы по 1С 7.7 [88]
1С: Бухгалтерия 7.7 [7]
1С: Торговля 7.7 [4]
1С:Зарплата и кадры 7.7 [1]
1С 7.7: Проблемы и решения [33]
УРБД [3]
Управление Распределенными Базами Данных
OLE [2]
Механизм обмена данными между базами 1С через OLE
SQL [1]
Сервер терминалов [1]
Интеграция с внешними приложениями [3]
FAQ по 1С v.7.7 [7]
FAQ по 1С v.7.7

Поиск

Поиск по сайту

Главная » Статьи » 1С v.7.7 » Общие вопросы по 1С 7.7

Удаление строк из таблицы значений с позиционированием
Удаление строк из таблицы значений с позиционированием
 
После выполнения процедуры в отчете заполняется таблица значений (ТЗ). На форме отчета создала кнопку Удалить, в формуле написала ТЗ.УдалитьСтроку(). Но после удаления определенной строки активизируется первая. А как сделать, чтобы активизированной была следующая строка после удаленной?

Удаленная=ТЗ.ТекущаяСтрока();
Если Удаленная>0 Тогда
   ТЗ.УдалитьСтроку();
   Если Удаленная>ТЗ.КоличествоСтрок() Тогда
      Удаленная=ТЗ.КоличествоСтрок();
   КонецЕсли;
   Если Удаленная>0 Тогда
      ТЗ.ТекущаяСтрока(Удаленная);
   КонецЕсли;
КонецЕсли;
КонецПроцедуры
Категория: Общие вопросы по 1С 7.7 | Добавил: Spacer (19.07.2008)
Просмотров: 3658
Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz

  • Статистика

    Copyright 1C:Programmer © 2016
    Бесплатный конструктор сайтов - uCoz