Кнопка для внешней обработки - Общие вопросы по 1С 7.7 - 1С v.7.7 - Каталог статей - Программирование в 1С
Программирование в 1ССреда, 07.12.2016, 12:36

| RSS
Главная | Каталог статей
Меню сайта

Категории раздела
Основы [36]
Общие вопросы по 1С 7.7 [88]
1С: Бухгалтерия 7.7 [7]
1С: Торговля 7.7 [4]
1С:Зарплата и кадры 7.7 [1]
1С 7.7: Проблемы и решения [33]
УРБД [3]
Управление Распределенными Базами Данных
OLE [2]
Механизм обмена данными между базами 1С через OLE
SQL [1]
Сервер терминалов [1]
Интеграция с внешними приложениями [3]
FAQ по 1С v.7.7 [7]
FAQ по 1С v.7.7

Поиск

Поиск по сайту

Главная » Статьи » 1С v.7.7 » Общие вопросы по 1С 7.7

Кнопка для внешней обработки
Кнопка для внешней обработки
 
Как создать кнопку на панели 1С 7.7 и привязать к ней внешнюю обработку?

   Создаете интерфейс, там есть панели инструментов, в поле список панелей создаете панель либо выбираете существующую, в окне состав панели создаете кнопку. Далее возможны два варианта:
 
Вариант 1:
В свойствах кнопки на закладке "Общие" указываете Объект: "Отчеты" и Команда: "Отчеты.ОткрытьВнешний". Затем на закладке "Параметры" указываете путь к внешнему отчету или обработке.
 
Вариант 2:
В свойствах кнопки на закладке "Общие" указываете Объект: "Задача" и Команда: "Задача.Выполнить". Затем на закладке "Параметры" в поле формула пишете: ОткрытьФорму(“полный путь к Вашей обработке”).
 
    Следует отметить, что второй вариант более гибкий, т.к. позволяет выполнять дополнительные действия перед вызовом обработки, например проверять наличие внешней обработки в указанном каталоге с выдачей предупреждения в случае ее отсутствия.
 
Пример:
В поле формула пишем: глОткрытьОтчет("ЛюбаяОбработка")
В глобальном модуле размещаем функцию:
// Открывает отчет или обработку
// Если отчет имеется в папке ExtForms информ. базы - открывается он.
// Если такого отчета нет в этой папке - открывается отчет в составе конфигурации

// ===============================
// Имя - имя отчета или обработки
// Конт - значение любого типа для передачи в открываемую форму

Функция глОткрытьОтчет(Имя,Конт=0,Модально=0) Экспорт
ИмяФайла = КаталогИБ()+"ExtForms\"+Имя+".ert";
Если ФС.СуществуетФайл(ИмяФайла) = 1 Тогда
   Если Модально=0 Тогда 
      Возврат ОткрытьФорму("Отчет",Конт,ИмяФайла); 
   Иначе 
      Возврат ОткрытьФормуМодально("Отчет",Конт,ИмяФайла); 
   КонецЕсли;
Иначе 
   Попытка 
      Если Модально=0 Тогда 
         Возврат ОткрытьФорму("Отчет."+Имя,Конт); 
      Иначе 
         Возврат ОткрытьФормуМодально("Отчет."+Имя,Конт); 
      КонецЕсли
   Исключение 
      Сообщить("В составе конфигурации отсутствует отчет """+Имя+"""!","!"); 
   КонецПопытки;
КонецЕсли;
Возврат 0;
КонецФункции
Категория: Общие вопросы по 1С 7.7 | Добавил: Spacer (20.07.2008)
Просмотров: 9240 | Комментарии: 1
Всего комментариев: 1
1  
Полезная информация (Вариант 2).

Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz

  • Статистика

    Copyright 1C:Programmer © 2016
    Бесплатный конструктор сайтов - uCoz