Анализ счета по субконто - 1С: Бухгалтерия 7.7 - 1С v.7.7 - Каталог статей - Программирование в 1С
Программирование в 1СВоскресенье, 04.12.2016, 01:48

| RSS
Главная | Каталог статей
Меню сайта

Категории раздела
Основы [36]
Общие вопросы по 1С 7.7 [88]
1С: Бухгалтерия 7.7 [7]
1С: Торговля 7.7 [4]
1С:Зарплата и кадры 7.7 [1]
1С 7.7: Проблемы и решения [33]
УРБД [3]
Управление Распределенными Базами Данных
OLE [2]
Механизм обмена данными между базами 1С через OLE
SQL [1]
Сервер терминалов [1]
Интеграция с внешними приложениями [3]
FAQ по 1С v.7.7 [7]
FAQ по 1С v.7.7

Поиск

Поиск по сайту

Главная » Статьи » 1С v.7.7 » 1С: Бухгалтерия 7.7

Анализ счета по субконто
Анализ счета по субконто
 
// Анализ счета по субконто
Дата1 = НачалоПериодаБИ();
Дата2 = КонецПериодаБИ();
Ит = СоздатьОбъект(“БухгалтерскиеИтоги”);
Ит.ИспользоватьСубконто(ВидыСубконто.ВидСубконтоДляОтбора);
Если Ит.ВыполнитьЗапрос(Дата1, Дата2, СчетПоКоду(“КодСчета”),,, 3) = 0 Тогда
   Возврат;
КонецЕсли;

Ит.ВыбратьСубконто();
Пока Ит.ПолучитьСубконто() = 1 Цикл
   Если ПустоеЗначение(Ит.Субконто()) = 1 Тогда
      Продолжить;
   КонецЕсли

   ПредставлениеСубконто = Ит.ПредставлениеСубконто(); 
   Ит.ВыбратьСчета(); 
   Пока Ит.ПолучитьСчет() = 1 Цикл 
      Ит.ВыбратьКорСчета(); 
      Если Ит.ПолучитьКорСчет(,СчетПоКоду("КодСчета”)) = 1 Тогда 
         // Возвращает кредитовый оборот между корреспонденциями 
         КорКО = Ит.КорКО(); 
         // Возвращает дебетовый оборот между корреспонденциями 
         КорДО = Ит.КорДО(); 
      КонецЕсли
   КонецЦикла;
КонецЦикла;
Категория: 1С: Бухгалтерия 7.7 | Добавил: Spacer (25.08.2008)
Просмотров: 2936
Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz

  • Статистика

    Copyright 1C:Programmer © 2016
    Бесплатный конструктор сайтов - uCoz