Анализ счета (запросом) - 1С: Бухгалтерия 7.7 - 1С v.7.7 - Каталог статей - Программирование в 1С
Программирование в 1СВоскресенье, 04.12.2016, 01:53

| RSS
Главная | Каталог статей
Меню сайта

Категории раздела
Основы [36]
Общие вопросы по 1С 7.7 [88]
1С: Бухгалтерия 7.7 [7]
1С: Торговля 7.7 [4]
1С:Зарплата и кадры 7.7 [1]
1С 7.7: Проблемы и решения [33]
УРБД [3]
Управление Распределенными Базами Данных
OLE [2]
Механизм обмена данными между базами 1С через OLE
SQL [1]
Сервер терминалов [1]
Интеграция с внешними приложениями [3]
FAQ по 1С v.7.7 [7]
FAQ по 1С v.7.7

Поиск

Поиск по сайту

Главная » Статьи » 1С v.7.7 » 1С: Бухгалтерия 7.7

Анализ счета (запросом)
Анализ счета (запросом)
 
// Анализ счета
// ——————
// использования запроса для работы с бухгалтерскими операциями и проводками.
// Запрос обрабатывает корреспонденции счета Сч
// по счетам КорСч за расчетный период.
// Значение счета для анализа задается в диалоге установкой ВыбСч.
//Создание объекта типа Запрос
Запрос = СоздатьОбъект(“Запрос”);
ТекстЗапроса =
|Период с Дата1 по Дата2;
|Сч = Операция.Счет;
|КорСч = Операция.КорСчет;
|Сумма = Операция.Сумма;
|Группировка Сч упорядочить по Сч.Код;
|Группировка КорСч упорядочить по КорСч.Код;
|Функция КорДо = КорДО(Сумма);
|Функция КорКо = КорКО(Сумма);
|Условие(Сч = ВыбСч);”;

//Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
   Предупреждение(“Запрос по бухгалтерскими операциями и проводками не выполнился!”);
   Возврат;
КонецЕсли;

//Подготовка к заполнению выходных форм данными запроса
Пока Запрос.Группировка(“Сч”) = 1 Цикл
   // Заполнение полей Сч 
   Сч = Запрос.Сч
   Пока Запрос.Группировка(“КорСч”) = 1 Цикл 
      // Заполнение полей КорСч 
      КорСч = Запрос.КорСч
      // Дальнейшая обработка... 
   КонецЦикла;
КонецЦикла;
Категория: 1С: Бухгалтерия 7.7 | Добавил: Spacer (26.08.2008)
Просмотров: 2577
Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz

  • Статистика

    Copyright 1C:Programmer © 2016
    Бесплатный конструктор сайтов - uCoz