Запрос по содержимому регистра - 1С: Торговля 7.7 - 1С v.7.7 - Каталог статей - Программирование в 1С
Программирование в 1СВоскресенье, 04.12.2016, 01:52

| RSS
Главная | Каталог статей
Меню сайта

Категории раздела
Основы [36]
Общие вопросы по 1С 7.7 [88]
1С: Бухгалтерия 7.7 [7]
1С: Торговля 7.7 [4]
1С:Зарплата и кадры 7.7 [1]
1С 7.7: Проблемы и решения [33]
УРБД [3]
Управление Распределенными Базами Данных
OLE [2]
Механизм обмена данными между базами 1С через OLE
SQL [1]
Сервер терминалов [1]
Интеграция с внешними приложениями [3]
FAQ по 1С v.7.7 [7]
FAQ по 1С v.7.7

Поиск

Поиск по сайту

Главная » Статьи » 1С v.7.7 » 1С: Торговля 7.7

Запрос по содержимому регистра
Запрос по содержимому регистра
 
Запрос = СоздатьОбъект(“Запрос”);

// Проверка на дату, до точки актуальности (ТА)
Если (Дата1>ПолучитьДатуТА()) и (Дата2>ПолучитьДатуТА()) Тогда
   Предупреждение(“Обе границы периода лежат за ТА ! Формирование невозможно !”,5);
   Возврат;
КонецЕсли;

Если Дата2 >= ПолучитьДатуТА() Тогда
   ТекстЗапроса = “Период с Дата1;”;
Иначе
   ТекстЗапроса = “Период с Дата1 по Дата2;”;
КонецЕсли;

// Основной текст запроса
ТекстЗапроса = ТекстЗапроса +
|Реквизит=Регистр.ВидРегистра.Реквизит;
|Док = Регистр.ВидРегистра.ТекущийДокумент;
|Сумма=Регистр.ВидРегистра.Сумма;
|Количество=Регистр.ВидРегистра.Количество;
|Группировка Реквизит без групп;
|Группировка Док;
|Функция НачОст=НачОст(Количество);
|Функция Приход=Приход(Количество);
|Функция Расход=Расход(Количество);
|Функция КонОст=КонОст(Количество);
|Условие (Реквизит в ВыбРеквизит);”;

// Выполнение запроса
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
   Предупреждение(“Запрос по регистру не выполнился!”);
   Возврат;
КонецЕсли;

// Группировки
Пока Запрос.Группировка(“Реквизит”) = 1 Цикл
   Реквизит = Запрос.Реквизит;
   Пока Запрос.Группировка(“Док”) = 1 Цикл
      Док = Запрос.Док;
      // Обработка полученных данных...
   КонецЦикла;
КонецЦикла;
Категория: 1С: Торговля 7.7 | Добавил: Spacer (30.08.2008)
Просмотров: 4884 | Теги: Регистр, Запрос
Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz

  • Статистика

    Copyright 1C:Programmer © 2016
    Бесплатный конструктор сайтов - uCoz