Открытие периода оперативных итогов - 1С: Торговля 7.7 - 1С v.7.7 - Каталог статей - Программирование в 1С
Программирование в 1СВоскресенье, 04.12.2016, 01:47

| RSS
Главная | Каталог статей
Меню сайта

Категории раздела
Основы [36]
Общие вопросы по 1С 7.7 [88]
1С: Бухгалтерия 7.7 [7]
1С: Торговля 7.7 [4]
1С:Зарплата и кадры 7.7 [1]
1С 7.7: Проблемы и решения [33]
УРБД [3]
Управление Распределенными Базами Данных
OLE [2]
Механизм обмена данными между базами 1С через OLE
SQL [1]
Сервер терминалов [1]
Интеграция с внешними приложениями [3]
FAQ по 1С v.7.7 [7]
FAQ по 1С v.7.7

Поиск

Поиск по сайту

Главная » Статьи » 1С v.7.7 » 1С: Торговля 7.7

Открытие периода оперативных итогов
Открытие периода оперативных итогов
 
// Открытие периода
ДатаТА = ПолучитьДатуТА();
Если (РабочаяДата() > ДатаТА) И ((ДатаМесяц(ДатаТА) <> ДатаМесяц(РабочаяДата())) ИЛИ (ДатаГод(ДатаТА) <> ДатаГод(РабочаяДата()))) Тогда
   Если МонопольныйРежим() = 0 Тогда 
      Ответ=Вопрос(“Не открыт период!” + РазделительСтрок + “Для открытия периода запустите программу в монопольном режиме!” + РазделительСтрок + “Завершить работу программы?”,“Да+Нет”); 
      Если Ответ=“Да” Тогда 
         СтатусВозврата(0); 
         Возврат
      КонецЕсли
   Иначе // монопольный режим 
      Ответ=Вопрос(“Не открыт период!”+ РазделительСтрок +“Выполнить открытие периода?”,“Да+Нет”); 
      Если Ответ=“Да” Тогда 
         УстановитьТАНа(РабочаяДата()); 
      КонецЕсли
   КонецЕсли;
КонецЕсли;
Категория: 1С: Торговля 7.7 | Добавил: Spacer (01.09.2008)
Просмотров: 3493
Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Друзья сайта
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz

  • Статистика

    Copyright 1C:Programmer © 2016
    Бесплатный конструктор сайтов - uCoz